أكثر

خطأ في الاتصال بـ SDE 10.3.1 على Oracle 12c من عميل 10.1

خطأ في الاتصال بـ SDE 10.3.1 على Oracle 12c من عميل 10.1


نحن نخطط حاليا لترحيل الخادم. لدينا خادمنا الحالي على SDE 10.1 على Oracle 11 حاليًا يعمل محررونا على ArcGIS 10.1 مع Oracle Client 11.2

خادمنا الجديد معد وجاهز للاختبار. إنه في SDE 10.3.1 على Oracle 12c. ومع ذلك ، عندما يحاول عملاء ArcGIS Desktop الحاليون الاتصال به ، فإنهم يحصلون على خطأ:

فشل الاتصال بقاعدة البيانات. خطأ DBMS الأساسي [خطأ غير معروف لا يوجد خطأ موسع]

.

كنت أعتقد أن الإصدارات الأحدث من SDE كانت متوافقة مع الإصدارات الأقدم من عملاء ArcGIS لسطح المكتب. هل هناك إعداد اتصال يجب أن يتغير؟ تعمل إعدادات الاتصال التي نستخدمها بشكل جيد مع ArcGIS Desktop 10.3.1:


وفقًا لوثيقة التوافق هذه ، يمكن لـ ArcGIS 10.1 الاتصال بـ Oracle SDE 10.3.1 فقط إذا كان أوراكل 10 أو 11.

يجب أن يكون نظام DBMS الأساسي هو Oracle 10g أو 11g. راجع متطلبات نظام ArcGIS 10.1 للإصدارات المدعومة.


فيما يلي بعض روابط الويب التي قد تكون مفيدة:

http://www.arcgis.com/home/item.html؟id=6997e32c54bd40ca8cahttp://ianbroad.com/arcgis-toolbox-create-unique-id-arcpy/13e1fdaf5948b

http://support.esri.com/technical-article/000011137